Home Support Modo Will my Advanced or Basic CAD Loader still work with Modo?

Modo

Will my Advanced or Basic CAD Loader still work with Modo?

Yes, both CAD loaders will work for both 701 and 801.
 
Dutch-NetherlandsEnglish (United Kingdom)
Now Available


Modo 12.1 officially available!

Read more here...

Requirements
Windows 7 - 10
Mac OS X 10.10 - 10.12
Linux RHEL 6.8+ & CentOS7+

**ONLY 64-Bit versions**

Intel 4Core 2.5Ghz or higher
16GB RAM or higher
OpenGL 4.4 Video Card 2+ GB

Buy & Pricing
Modo starts at:

€ 1.619,-

Click here for all prices.

Buy & Pricing
Modo Kits & Plugins start at:

€ 45,-

Click here for all prices.

Order Now


Order Modo and additional kits and plugins through our webshop